Description
WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.
Published: 2026-10-31
Score: 8.1 High
EPSS: < 1% Very Low
KEV: No
Impact: n/a
Action: n/a
AI Analysis

Analysis and contextual insights are available on OpenCVE Cloud.

Remediation

No vendor fix or workaround currently provided.

Additional remediation guidance may be available on OpenCVE Cloud.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 02 Nov 2026 12:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-552
References
Metrics threat_severity

None

threat_severity

Important


Sat, 31 Oct 2026 05:45:00 +0000

Type Values Removed Values Added
Description WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.
Title WordPress Core 4.7.0 - 7.1.3 - Unauthenticated Upgrade-Window Staged-Installer Remote Code Execution
Weaknesses CWE-367
References
Metrics cvssV3_1

{'score': 8.1, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-31T05:33:07.059Z

Reserved: 2026-10-30T17:17:35.145Z

Link: CVE-2026-119977

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-31T06:16:34.550

Modified: 2026-10-31T06:16:34.550

Link: CVE-2026-119977

cve-icon Redhat

Severity : Important

Publid Date: 2026-10-31T05:33:07Z

Links: CVE-2026-119977 - Bugzilla

cve-icon OpenCVE Enrichment

Updated: 2026-10-31T06:30:15Z

Weaknesses